Back to overview
Downtime

Visualizer was down

Oct 04 at 03:32am CEST

Resolved
Oct 04 at 03:53am CEST

Visualizer recovered.

Created
Oct 04 at 03:32am CEST

Visualizer was temporarily unavailable due to an unknown issue with the hosting provider's database.