Back to overview
Downtime

Database unavailability

Oct 12, 2023 at 09:35am UTC

Resolved
Oct 12, 2023 at 10:10am UTC

It's all back now.

Apologies for all inconvenience caused.

Created
Oct 12, 2023 at 09:35am UTC

I did some DB maintenance and it went wrong.